Get 20% Off On All Our Premium WordPress Themes Bundle. Use GRACEBFCM Coupon Code For Discount Deal Upto Dec 15 Buy Now

How to Fix Pluggable.php File Errors in WordPress


From starting an e-commerce website to starting a blog about your passion, WordPress programs can help you in creating your website. WordPress is basically a content management system (CMS), which manages the content that you put on your website and is widely used for creating blogging websites.

WordPress is open source software written in PHP, which allows you to download its scripts and use an easy to use, web-based editor for creating your WebPages. With WordPress, you can be online within a few minutes. It also allows you to customize the websites using a number of plug-in scripts available online. You can choose products from any custom software development company download and install it to have the desired feature on your website. There are many such companies that offer plug-ins specifically designed for WordPress.

However, like any other platform, there are some common errors that you may come across while working with WordPress. One such error that troubles the users quite often is the pluggable.php file error. In some cases, your website may still continue to work despite the error message appearing in the admin area. The pluggable.php file error appears to be a serious and complicated error but if it is understood correctly, it is can be resolved by taking simple steps.

The Reason of Pluggable.php File Error

Before you dive into the code and start editing it to fix an error, it is important to understand the main reason that could have caused the error. An initial look at the Pluggable.php file error makes you think that the error is in the pluggable.php file. Conversely, the reason for the error in most of the cases is something else. In fact, the pluggable.php is a core file of WordPress and should not be edited.

As stated previously, WordPress allows you to add custom made plug-ins or themes to boost the features. The majority of the users of WordPress are nontechnical, which is why, most of the time, the downloaded custom codes snippets are played on live websites without any testing on a local environment. Any conflict between these incorporated plug-ins or themes and core WordPress functions can serve as the primary cause for the pluggable.php file error.

Understanding a Pluggable.php File Error on Screen

Whenever a new function in any of the added code snippets overrides a core WordPress function and it is unable to handle it the right way, the pluggable.php file error occurs.

A pluggable.php file error pops up on the screen as a path of a location where it has occurred. It is important to understand the actual meaning that it reflects. In general, a pluggable.php file error looks something like the following warning message.

Warning: Cannot modify header information – headers already sent by (output started at /home/user/dummysite/wp-content/themes/newtheme/functions.php:1153) in /home/user/dummysite/wp-includes/pluggable.php on line 1708

The above example shows the pluggable.php file with a line number appearing at the end of the warning message. This prompts the users to edit the pluggable.php file in order to debug and fix the error.

In order to fix the pluggable.php file error, you should always look at plug-in or theme that the initial part of the error message is pointing to.

Warning: Cannot modify header information – headers already sent by (output started at /home/user/dummysite/wp-content/themes/newtheme/functions.php:1153) in /home/user/dummysite/wp-includes/pluggable.php on line 1708

Just as highlighted in the above example the initial part of the error message points towards a theme that you might have downloaded and added to your website to add a new feature or improve an existing one. It is this plug-in that is causing the error and needs your attention.

Fixing a Pluggable.php File Error

A pluggable.php file error is much easier to fix, provided the location of its occurrence is precisely known. It is also simple to locate the error by carefully looking at the error message on your screen.

Warning: Cannot modify header information – headers already sent by (output started at /home/user/dummysite/wp-content/plugins/myplugin/myplugin.php:227) in /home/user/dummysite/wp-includes/pluggable.php on line 1084

In the above example, the error is not at line no 1084 of the pluggable.php file. The error has actually occurred in myplugin.php at line no 227 as pointed by the former part of the displayed message. The above error indicates that you have to edit or omit the code in the myplugin.php file in order to fix the error.

There can be a number of possible ratification steps, which you can follow to remove the error and get your website working.

  • Remove Extra Spaces

    The most simple coding error that can cause the error is an extra space after the closing PHP tag ‘?>’. If this is the case then all you need to do is to remove this extra space and get your codes functioning.

  • Edit or Remove Custom Code Snippets or Functions

    WordPress also allows you to add code snippets to the function.php file to improve a feature or as a new theme. If you have been facing this error since you have added any such code, you have to either edit the newly add code to fix the error or you can simply remove the code. Certainly, the file name, function.php and the line number will be displayed in the error message.

  • Deactivate Plug-in

    If you have downloaded and installed a new plug-in that is conflicting with the handling of the core WordPress function then the best way to get rid of the error is to deactivate the plug-in and report the error to the plug-in author.

    Even the WordPress official repository has a number of third-party plug-ins. When you install a core update for WordPress, a plug-in with an old coding standard that was functioning well earlier may now start conflicting. Again the best action to be taken is to deactivate the plug-in and report the error.

With the above-mentioned solutions, you can easily fix a pluggable.php file error by paying a little attention to the path and finding the file that is causing the error. Using custom plug-ins and themes is inevitable for website development; they can become culprits to some serious issues on your website. For this reason, it is advisable to be more careful while downloading any such plug-in or theme. If you want more help on developing and maintaining a website using word press, get free website help: where to navigate and who to ask (with 9 examples) by HuffPost can provide you insight on resolving your website development issues.